Baekjoon 단어 공부

최대 1 분 소요

문제설명

알파벳 대소문자로 된 단어가 주어지면, 이 단어에서 가장 많이 사용된 알파벳이 무엇인지 알아내는 프로그램을 작성하시오. 단, 대문자와 소문자를 구분하지 않는다.

입력

첫째 줄에 알파벳 대소문자로 이루어진 단어가 주어진다. 주어지는 단어의 길이는 1,000,000을 넘지 않는다.

출력

첫째 줄에 이 단어에서 가장 많이 사용된 알파벳을 대문자로 출력한다. 단, 가장 많이 사용된 알파벳이 여러 개 존재하는 경우에는 ?를 출력한다.

예제 입력 1

Mississipi
zZa
z
baaa

예제 출력 1

?
Z
Z
A

풀이

소스코드
import java.util.*;

public class Main {
    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        
        String st = sc.nextLine().toUpperCase();
        
        int[] cnt = new int[26];
        int max = 0;
        char result = '?';
        
        for(int i = 0; i < st.length(); i++) {
            cnt[st.charAt(i)-65]++;
            
            if(max < cnt[st.charAt(i)-65]) {
            	max = cnt[st.charAt(i)-65];
            	result = st.charAt(i);
            }else if(max == cnt[st.charAt(i)-65]) {
            	result = '?';
            }
        }
        System.out.println(result);
    }
}

카테고리:

업데이트:

댓글남기기